Connecting New Type A to Simplify 3D via USB

A space for working on issues specific to Series 1. Includes Beta groups and production machines.

Moderator: Elijah

Sean
Posts: 11
Joined: Mon Feb 02, 2015 9:17 am

Connecting New Type A to Simplify 3D via USB

Postby Sean » Mon Feb 02, 2015 9:21 am

I just got my new Type A Machine. I have been using Simplify 3D with other printers and would like to use it again on the Type A. However, I can't seem to get my computer to talk to the machine. I am using the USB-B port on the back of my printer to go directly to my computer. Has anyone been able to pull this off? I see on the older machines you can go directly to the board inside but with all the USB ports on the newer model there surely has to be a way to connect without having to do that... Thanks for any help!

astalsi
Posts: 138
Joined: Fri Nov 08, 2013 2:14 pm

Re: Connecting New Type A to Simplify 3D via USB

Postby astalsi » Mon Feb 02, 2015 2:11 pm

If I remember correctly, the direct-to-RUMBA configuration is no longer supported. See this post.

If you still want to go ahead with it, you will need to open the e-tray at the bottom and change which cable is plugged into the RUMBA. Right now, there's one from a little USB hub (probably blue). You need to change it for whichever port you wish to use.

I hope this helps.

Steve

Edited to add link to old post.

Matthew
Posts: 126
Joined: Wed May 14, 2014 12:40 pm

Re: Connecting New Type A to Simplify 3D via USB

Postby Matthew » Mon Feb 23, 2015 9:11 am

Steve is correct. A direct to Rumba connection is not supported.

Here's how - Set your COM port to 230400 baud. You'll also need configure the Series 1 build volume as 305mm^3 and the nozzle as 0.40mm.

-matthew-
I'm from support. I'm here to help.

Sean
Posts: 11
Joined: Mon Feb 02, 2015 9:17 am

Re: Connecting New Type A to Simplify 3D via USB

Postby Sean » Tue Oct 06, 2015 8:25 am

This can actually be done. I have been running my Type A with Simplify 3D for about 8-months now with a direct USB connection. I am feeling guilty that I haven't come back to update this... So it is due time. Seeing that it has been a while I might be missing a few steps and tweaks that have evaporated from my memory. Here is the basic steps:

1. You are going to need to buy two cables. First, get a long USB cable with "A to B" connections to connect you computer to the machine. The back of your machine has a "B" fitting. I actually found that the fitting is a little weak so make sure to check the leaflets are making good contact or you will intermittently lose connection for no apparent reason. Second, you need to get a short jumper for inside the machine with "mini B male-to-mini B female" ends (~6inches will work). See a note on this in step #5 for what not to do.

2. Unplug your machine. Then take off the access panel by removing the four (4) socket head screws using a 2mm allen wrench. Put on wool socks and walk around the carpet, scuffing your feet vigorously, for about 6.5 minutes. Just kidding... I recommend that you wear a grounding strap before tinkering with the circuitry (on anything).

3. Locate the USB B fitting on the back of the machine next to the Ethernet cable jack. Follow that internally to the Beaglebone Black board on the left side of the tray. Unplug it (see image below). This port will remain unused unless you need to update the firmware on the SD card. In which case just connect the cable back.

Beaglebone-Black-Disconnect.jpg
This is where you need to disconnect your Beaglebone board.
Beaglebone-Black-Disconnect.jpg (319.32 KiB) Viewed 3012 times


4. Now locate the white RUMBA board located at the center of the tray. There should only be one mini B USB connection facing the front of the machine. Disconnect that as well (see image below). Optional: This cable you just disconnected is no longer needed. If you want to remove it then you can disconnect it from the blue USB hub and take it out entirely. If you want to return the to the original configuration I would leave it there so you don't lose it.

Rumba-Disconnect.jpg
This is where you need to disconnect your RUMBA board.
Rumba-Disconnect.jpg (323.46 KiB) Viewed 3012 times


5. Now you are going to bridge the loose cable from the back of the machine to the RUMBA using the short USB mini B male-to-mini B female cable. I tried to be cute here and got a 90° cable so that it would look cleaner, but that backfired as the 90° went the wrong way as you can see in the picture below. This is the exact cable I used: http://www.amazon.com/gp/product/B00IFG9FDO. So don't do that... Just get a straight one.

Final-USB-Wiring.jpg
Here is how it should look when done (except for the stupid 90° connector going the wrong way).
Final-USB-Wiring.jpg (404.2 KiB) Viewed 3012 times


6. Alright, you are done with the hardware changes so you can close it up. Here is where my memory gets hazy... After messing with other 3D printers I forget what I had already installed on my computer for drivers. I am 99% sure that I already had RUMBA drivers installed. I am also 99% sure that you will need to do the same as you are now directly connected to the board. So locate the latest version and install it. Reboot.

7. You should now be able to connect directly via the Simplify 3D (S3D) program. I have done so much messing around in S3D, I forget exactly what I changed around to make this work better. It should work now as is. Make sure your baud rate it 230400 if you can't connect at first. I was having intermittent connectivity issues but I am not sure if it was from a weak physical connection at the back of the printer or settings that I tweaked in S3D. I am also pushing it with a 25' cable which could have something to do with it. Here are some things that I changed in S3D that might have helped:

- Under "Tools>Firmware Configuration>Advanced" activate "Allow command buffering", adjust your "Serial cache size" to as much as you can, use "No Flow Control", and deactivate "Communication timeout". If you are using an older version of S3D just jack up the timeout limit to 99999 seconds.

- Your firmware should already be set to "RepRap (Marlin/Repetier/Sprinter)" but if it isn't change that and make sure under your printing profiles in the "Show Advanced>G-Code (tab)>Update Firmware Configuration" it isn't changing it to something else when you go to print.

- In the same tab, I am activating following settings that should already be set from the S3D install if you selected the Type A profile: 5D firmware, Relative extrusion distances, Allow zeroing of extrusion distances, and Firmware supports "sticky" parameters.

Okay. That is it. I hope this helps someone! Printing directly from the S3D interface has been really nice and the new version (3.0.2) is much better and making some killer prints for me.

-Sean

Elijah
Site Admin
Posts: 767
Joined: Wed Oct 10, 2012 6:33 pm

Re: Connecting New Type A to Simplify 3D via USB

Postby Elijah » Thu Oct 08, 2015 1:33 pm

Great tutorial. Indeed it can be done, just not under the Type A workflow.
Elijah Post
Type A Machines


Return to “Series 1”

Who is online

Users browsing this forum: No registered users and 1 guest