Page 1 of 2

Welcome! configs and firmware

Posted: Thu Dec 06, 2012 10:53 am
by AndrewRutter
Welcome one and all.

Our first wave of Dual Head machines is out there and this is the place to share knowledge!

Attached you will find the current Slic3r profile. We do not yet have a KISSlicer profile (but the Pro version should be simple to configure for Dual Head).

Update
Firmware attached!
11-12-12 Firmware with correct author and date added.

Share your results and improvements!

Re: Welcome!

Posted: Thu Dec 06, 2012 10:16 pm
by LaserGnomes
...exactly what I was looking for. THANKS!

Re: Welcome! configs and firmware

Posted: Sun Dec 09, 2012 8:00 pm
by Rodwagner
Perfect ignore my post on .ini now how about a good test .stl

Re: Welcome! configs and firmware

Posted: Tue Dec 11, 2012 9:25 am
by pwiseman
I just bought this machine from Makershed. I'd like to start with just one extruder, so should I use the single-extruder slic3r profile until I'm ready to try two?

Patrick

Re: Welcome! configs and firmware

Posted: Tue Dec 11, 2012 10:56 am
by AndrewRutter
pwiseman wrote:I just bought this machine from Makershed. I'd like to start with just one extruder, so should I use the single-extruder slic3r profile until I'm ready to try two?

Patrick


Yes. By default the machine will use the first (left) extruder (T0). If your g-code does not include T0 and T1 commands (they switch the active toolhead) then you'll just get a single head print. You could even add the T1 command into the start custom g-code to make the machine print with the second head.

Using second head as primary?

Posted: Tue Dec 25, 2012 11:09 am
by pwiseman
AndrewRutter wrote:You could even add the T1 command into the start custom g-code to make the machine print with the second head.


Could you explain how? I've created a Slic3r profile setting extruder 2 to do everything, setting the center x-coordinate to 130 to compensate for the 30.5mm offset of the second extruder, and I've modified the start g-code to zero the temp on T0 and then use only T1, but in the generated g-code there's a reference to T0, followed by lots of G1 movements to X coordinates which look to be 30 off, and, after printing a few layers, the head moved 30mm to the left to continue. Maybe it's a bug in Slic3r (I'm using version 0.9.8-dev) or maybe I just don't know what I'm doing!

Patrick

Re: Using second head as primary?

Posted: Tue Dec 25, 2012 2:36 pm
by pwiseman
pwiseman wrote:I've created a Slic3r profile setting extruder 2 to do everything, setting the center x-coordinate to 130 to compensate for the 30.5mm offset of the second extruder, and I've modified the start g-code to zero the temp on T0 and then use only T1, but in the generated g-code there's a reference to T0, followed by lots of G1 movements to X coordinates which look to be 30 off, and, after printing a few layers, the head moved 30mm to the left to continue.


I MAY have solved this by setting the X-offset for the second extruder to 0; now, although the generated T-code invokes T0, the X-coords are not off when compared with those for T1. I can just comment out the T0 call, and everything should now work for T1. I haven't had a chance to put it to the test yet.

Patrick

Re: Using second head as primary?

Posted: Wed Dec 26, 2012 6:55 am
by pwiseman
pwiseman wrote:I MAY have solved this by setting the X-offset for the second extruder to 0; now, although the generated T-code invokes T0, the X-coords are not off when compared with those for T1. I can just comment out the T0 call, and everything should now work for T1. I haven't had a chance to put it to the test yet.


That worked, but I had another problem, reporting in the Troubleshooting forum.

Patrick

Re: Welcome! configs and firmware

Posted: Mon Feb 18, 2013 1:25 pm
by LaserGnomes
Umm... few issues with this Slic3r file.


1. Extrusion default is 1mm? Andrew advised 0.35-0.6
2. Start G-Code has SEVERAL temperature calls which seem unnecessary

-2 cents

Re: Welcome! configs and firmware

Posted: Mon Feb 18, 2013 1:40 pm
by pwiseman
LaserGnomes wrote:Umm... few issues with this Slic3r file.


1. Extrusion default is 1mm? Andrew advised 0.35-0.6
2. Start G-Code has SEVERAL temperature calls which seem unnecessary


It's the default slic3r profile, supplied by TAM.

You're right about the unnecessary temperature calls at the beginning of the file. I'm not sure they even work, given the "M104 S135 T0" format; I think you need "T0\nM104 S135" for it to take.

Patrick